bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bash test: lastpipe.tests failed


From: address@hidden
Subject: Re: bash test: lastpipe.tests failed
Date: Fri, 12 Aug 2016 16:06:01 +0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.7.2

But when I run the test line by line, it's OK.

I used the version of bash is 4.3.30 on master branch, run the test on
the qemux86-64.

On 2016年08月10日 19:16, Chet Ramey wrote:
On 8/10/16 3:32 AM, address@hidden wrote:
Hi all

When I run the bash test lastpipe.tests, there were some errors occurred.

The code in lastpipe.tests:

     shopt -s lastpipe
     ...
     exit 142 | false
     echo $? -- address@hidden

The error output:

     lastpipe.tests: line 41:   708 Exit 142                exit 142
     703 Hangup                  | false
     129 -- 142 129
I can't reproduce this.  It looks system-specific; there shouldn't be
anything sending a SIGHUP to a simple command there.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]