bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling bash statically in 4.2/4.3/4.4 with GCC 6.1.0


From: Chet Ramey
Subject: Re: Compiling bash statically in 4.2/4.3/4.4 with GCC 6.1.0
Date: Thu, 11 May 2017 11:46:07 -0400
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:52.0) Gecko/20100101 Thunderbird/52.1.0

On 5/11/17 10:56 AM, Steve Volumetric wrote:
> In addition to my previous email, I also tired older versions of bash,
> going back to 4.2
> 
> I get the exact same error with all of them with the only exception being
> that the error occurs on different lines, but it always boils down to this:
> 
> ./config.h:332:22: error: two or more data types in declaration specifiers
>  #define sig_atomic_t int

If you don't have the static C libraries installed -- and I don't know
whether they are an available package for your version of Linux -- no
configure test that requires compiling a program will succeed. It doesn't
matter, though, because even if you're able to construct a correct
config.h, the result won't link.

-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
                 ``Ars longa, vita brevis'' - Hippocrates
Chet Ramey, UTech, CWRU    address@hidden    http://cnswww.cns.cwru.edu/~chet/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]