bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: error: ‘eval_builtin’ undeclared


From: Chet Ramey
Subject: Re: error: ‘eval_builtin’ undeclared
Date: Tue, 30 Jan 2018 14:17:38 -0500
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:52.0) Gecko/20100101 Thunderbird/52.5.2

On 1/30/18 2:07 PM, Larissa Braz wrote:

> I was running it using Ubuntu 14.04 LTS. I used the README instructions:
> "To compile Bash, type `./configure', then `make'. "
> 
> git clone http://git.savannah.gnu.org/git/bash
> <http://git.savannah.gnu.org/git/bash>
> ./configure
> make
>  
> 
>     There doesn't seem to be. Running these commands on an ubuntu 14.04 system
>     with gcc-4.8 results in a working bash binary:
> 
> 
>     git clone http://git.savannah.gnu.org/git/bash
>     <http://git.savannah.gnu.org/git/bash>
>     cd bash
>     bash ./configure -C
>     make
>     ./bash -c 'echo $BASH_VERSION'
>     ./bash --version
> 
> The error disappears when I use "bash ./configure -C" instead of just
> "./configure". Is it ok to use it instead of the README instructions?

I think it's something specific to your system.

I ran `bash ./configure ; make' and got a working binary. I ran
`sh ./configure ; make' and `./configure ; make' (they're equivalent)
and got working binaries with both.

I guess you should do whatever your system needs to get a working binary.

Chet

-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
                 ``Ars longa, vita brevis'' - Hippocrates
Chet Ramey, UTech, CWRU    address@hidden    http://tiswww.cwru.edu/~chet/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]