[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

make install failed; dump core in mkdir

From: George R Goffe
Subject: make install failed; dump core in mkdir
Date: Sun, 1 Dec 2019 15:20:54 +0000 (UTC)


This is really strange. I just did a buld of bash-5.0 from ftp.gnu.org. build 
went well... but make install coredumped in mkdir. mkdir is in my bashrc...This 
is not a new change to the bash rc file. 

mkdir ()
for dir in $dirs;
/bin/mkdir -p "$dir";

make[1]: Leaving directory '/export/home/tools/bash/bash-5.0/po'
( cd /tools/bash/bash-5.0/examples/loadables && make  DESTDIR= install )
make[1]: Entering directory 
../../support/mkinstalldirs: line 53: 1822305 Segmentation fault      (core 
dumped) mkdir -p -- . 2> /dev/null
mkdir /usr/lsd/Linux/lib/bash
../../support/mkinstalldirs: line 74: 1822313 Segmentation fault      (core 
dumped) mkdir "$pathcomp"
make[1]: *** [Makefile:246: installdirs] Error 139
make[1]: Leaving directory '/export/home/tools/bash/bash-5.0/examples/loadables'
make: [Makefile:824: install] Error 2 (ignored)

trying without the bashrc function. Sigh...

same result. bash/examples/loadables has a mkdir! Why would make install try to 
mkdir for the "current" directory? 

I removed mkdir from the Makefile and named it xx... make -f xx install worked!

Any thoughts?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]