[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with reverse-i-search in 5.1.0(1)-rc1

From: Detlef Vollmann
Subject: Re: Problem with reverse-i-search in 5.1.0(1)-rc1
Date: Sun, 1 Nov 2020 14:11:18 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.4.0

On 10/31/20 4:00 PM, Detlef Vollmann wrote:

since Bash-5.1-rc1 <CTRL-R> doesn't work for me as previously.
I have the following entries in my history:
man a
man b

Now I type '<CTRL-R> m a n' and get:
(reverse-i-search)`man': man b

Now I type '<CTRL-R>' again.
What I would expect (and what I got with 5.0) is:
(reverse-i-search)`man': man a

Instead I get
(reverse-i-search)`': man b

Note the empty search string.
I can type '<CTRL-R>' as often as I want, but always get the same
I can type the same search string again and will stay at 'man b'.

If I now type '<CTRL-G>' to cancel the search, I get my prompt
and then still 'man b'.

If I never type '<CTRL-R>' a second time, '<CTRL-G>' works
properly (my prompt, but no command).

If I get the empty search string, I can also type a different
search string and reverse-i-search will show me a correct
match or a failure message.  If I now cancel with '<CTRL-G>',
I still get 'man b', even if a different command was shown
in the failure message.

I've tested this with the Debian package bash 5.1~rc1-2 and a
self-compiled version, no difference.

I've tested this with a test user that has no .bash*, .profile,
.inputrc, also no difference.

I've tested this on xterm, lxterminal and the Linux console
(i.e. no X11).  The only difference was that on the Linux
console the matched part of the command was highlighted.
I didn't see any highlighting in xterm.

My system is a Debian Sid, bash version string is
GNU bash, version 5.1.0(1)-rc1 (x86_64-pc-linux-gnu)

This seems the same problem as described here:
except thai I normally don't see highlighting.

If you need any more information, please ask.

Ok, I could narrow it down.
I'm one of those dinasaurs who still prefer the POSIX locale.
If I run 'LANG=en_US.utf8 bash' <CTRL-R> works as expected.
(Some other things break, but that's a different story...)

So you should be able to reproduce the problem using
'LANG=POSIX bash'.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]