[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Unclosed quotes on heredoc mode

From: João Almeida Santos
Subject: Unclosed quotes on heredoc mode
Date: Wed, 17 Nov 2021 12:35:42 +0000


First of all thank you for doing great (and free) software!
I’m a programming student currently on 42 School in Lisbon, and one of our 
projects is to create a minishell, and to mimic the behavior of bash. 
While testing the heredoc mode, I realized that the $ is not interpreted as 
variable expansion. That’s interesting.
But the reason why I’m emailing you is that I whenever I tried to use an 
unclosed quote on heredoc, it doesn’t seem to handle well…it never finishes the 
I tried \n for paragraph, verbatim inserting enter, closing quotes on the next 
line, …don’t know what else to test.
I’m on version 5.1 btw.
Is this an expected behavior or a bug?

Thank you!

Kind regards,
João Almeida Santos

reply via email to

[Prev in Thread] Current Thread [Next in Thread]