[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

binutils: objdump --disassemble -g: "no recognized debugging information

From: Andrew Pimlott
Subject: binutils: objdump --disassemble -g: "no recognized debugging information"
Date: Thu, 20 Nov 2003 08:09:31 -0500
User-agent: Mutt/1.5.4i

I reported the following as a Debian bug[1] but received no reply,
so I'll forward it to you.  I am using Debian binutils package
version on Debian "testing".

objdump --disassemble -g normally gives a nice assembly listing
annotated with the original source code.  However, when I tried this
recently, I got the error "no recognized debugging information" and no
source code.  This can be demonstrated with a trivial program:

    % echo "int main(int argc, char **argv) { return 0; }" > try.c
    % gcc-3.3 -g -c try.c
    % objdump --disassemble -g try.o > /dev/null
    objdump: try.o: no recognized debugging information

My gcc-3.3 is 1:3.3.2-0pre5, and 3.2 gives the same result.  I tried
other debugging flags to gcc, like -ggdb and -g3, with no difference.
However, if I use gcc-2.95, objdump works as expected.  Since it varies
by gcc version, I suppose it may be gcc's fault, but since gcc's the de
facto standard, I imagine objdump ought to accomodate if possible.


[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=218070

reply via email to

[Prev in Thread] Current Thread [Next in Thread]