[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: binutils-2.15 as --target=sh-elf trivially broken

From: Nick Clifton
Subject: Re: binutils-2.15 as --target=sh-elf trivially broken
Date: Fri, 30 Jul 2004 16:47:26 +0100
User-agent: Mozilla Thunderbird 0.7 (X11/20040615)

Hi Toshi,

It looks like binutils-2.15 is trivially broken for target sh-elf.
When I try to build gcc --target=sh-elf with as from binutils-2.15, here's
what happens:

address@hidden gcc]$ sh-elf-as unwind-dw2.s
unwind-dw2.s: Assembler messages:
unwind-dw2.s:4732: Error: attempt to move .org backwards

I tried to reproduce this problem using the current 2.15 sources (from the branch in the CVS repository) and the mainline CVS sources - both versions worked fine and did not produce an error. This was on an x86 host run Linux.

Can you try using the latest binutils sources and see if the problem still exists for you ? if so, please could you tell us more about how you built the toolchain and in what kind of environment it is running.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]