[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: binutils-2.15 as --target=sh-elf trivially broken

From: tm_gccmail
Subject: Re: binutils-2.15 as --target=sh-elf trivially broken
Date: Sat, 31 Jul 2004 00:29:49 -0700 (PDT)

On Fri, 30 Jul 2004, Nick Clifton wrote:

> Hi Toshi,
> > It looks like binutils-2.15 is trivially broken for target sh-elf.
> > When I try to build gcc --target=sh-elf with as from binutils-2.15, here's
> > what happens:
> > address@hidden gcc]$ sh-elf-as unwind-dw2.s
> > unwind-dw2.s: Assembler messages:
> > unwind-dw2.s:4732: Error: attempt to move .org backwards
> I tried to reproduce this problem using the current 2.15 sources (from 
> the branch in the CVS repository) and the mainline CVS sources - both 
> versions worked fine and did not produce an error.  This was on an x86 
> host run Linux.
> Can you try using the latest binutils sources and see if the problem 
> still exists for you ?  if so, please could you tell us more about how 
> you built the toolchain and in what kind of environment it is running.
> Cheers
>    Nick

It could be due to the older gcc I'm using:

gcc version 2.96 20000731 (Red Hat Linux 7.0)

I'll upgrade to 3.3.4 and see if it changes things.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]