[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug binutils/782] objdump not working for target rs6000-aix

From: dddu88 at cox dot net
Subject: [Bug binutils/782] objdump not working for target rs6000-aix
Date: 10 Mar 2005 05:42:46 -0000

------- Additional Comments From dddu88 at cox dot net  2005-03-10 05:42 -------
Hi, Ben, I just downloaded the new released source code for today, and tested
again, it really worked for me. thanks for your testing.


(In reply to comment #2)
> Hi, Ben, what is your source/src directory, I downloaded the binutils-2.15
> source code, there is no source/src directory, the directory structure I have 
> is
>  binutils-2.15/binutils, there are two cases of running configuring target and
> running the make file, one is under directory binutils, the other is under
> binutils-2.15/binutils, because there are both configure and make files, my
> questions are:
> 1. so where you run them respectively? under binutils-2.15 or under
> binutils-2.15/binutils? when I ran them under binutils-2.15/binutils, I got 
> the
> error in the bug report, and I could not run them under binutils-2.15, it gave
> me make error:
> configure: loading cache ./config.cache
> configure: error: `target_alias' has changed since the previous run:
> configure:   former value:  i686-pc-cygwin
> configure:   current value: rs6000-aix
> configure: error: changes in the environment can compromise the build
> configure: error: run `make distclean' and/or `rm ./config.cache' and start
> over
> make: *** [configure-libiberty] Error 1
> 2. Could please try objdump -i, see what you will get? and what is your foo.o
> object format? I need to dump xcoff format object file, is the foo.o in xcoff
> format?
> 3. Could you please send me your objdump.exe file or rename to objdump.tmp 
> (just
> in case you could not send exe file) and send to me?
> 4. What is your binutils version? is it 2.15? and where have you downloaded? 
> Thanks
> David
> (In reply to comment #1)
> > I built a copy of binutils like so:
> >   ~/source/src/configure --target=rs6000-aix && make all-binutils
> > 
> > and ran objdump directly from the build directory like so:
> >   ./binutils/objdump -d foo.o
> > 
> > It worked.

           What    |Removed                     |Added
             Status|REOPENED                    |RESOLVED
         Resolution|                            |FIXED


------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]