[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

issue with -R option coupled with -Xlinker gcc option

From: Michael Anburaj
Subject: issue with -R option coupled with -Xlinker gcc option
Date: Thu, 11 Aug 2005 22:35:32 -0700 (PDT)


Tool detail:
Arm-elf-gcc version : 4.0.0
Arm-elf-ld version : 2.15

This issue is to do with the –R linker option. Usually
with other tool-chains you provide the symbol file to
the link step to link a different image in a separate
memory region. But, in case of gcc (mipsisa32-elf-gcc)
I supply the elf output of one image to the link step
of 2nd image with the –R linker option & it worked.
I tried the same with ARM architecture (arm-elf-gcc) &
provided the –R option to gcc coupled with the
–Xlinker option & it produces the following error:

arm-elf-gcc ramcode.o frmwrk.o consol.o led.o rtc.o
stke.o ac_armdefs.o ac_halt.
o init.o -mcpu=arm7tdmi  -nostartfiles  -T
.ld -Wl,-Map=symfiletest_ram.map,--cref -o
symfiletest_ram.elf -Xlinker -R -Xlin
ker ./../../rom/bin/romlib_ram.elf
internal er
ror: aborting at ../../binutils-2.15/ld/ldlang.c line
3835 in lang_place_orphans

please repo
rt this bug
collect2: ld returned 1 exit status
make: *** [symfiletest_ram.elf] Error 1

Please help me with this issue!!


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]