[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How to overcome the problem created when binutils is installed?

From: Sandeep Kumar
Subject: Re: How to overcome the problem created when binutils is installed?
Date: Thu, 19 Jan 2006 17:29:08 +0530

On 1/19/06, Nick Clifton <address@hidden> wrote:
> Hi Ashwani,
> >    i have fedora core 3 distribution with gcc version 4.0 .When i
> > installed binutils 2.13
> 2.13 is a very old release.  You really should be using the 2.16
> release, which you ought to have found included with the gcc 4.0
> distribution that you are using.
> > each and every program when compiled gave an
> > error Collect2 : ld 1 exit status (something like that) . I removed the
> > libraries ( e.g libiberty.a ,etc) from the directory of /usr/lib .But
> > the problem remained. Can anybody tell me what happens to the loader
> > after the bintuils is installed and how to overcome it ?
> Neither collect2 nor ld is a loader.  The former is a wrapper program
> which invokes the latter.  ld is a linker.
> If you still have the problem after switching over to the 2.16 binutils
> release then may I suggest adding the --verbose switch to the linker
> command line ? (presumably via adding -Wl,--verbose to your gcc command
> line).  This may help you track down where in the linker the problem is
> occurring.

But I think that once if he starts getting that error, i dont think
that Binutils 2.16 will be installed. He will have to first correct
the problem with the ld and then he can go on with the new
I had the same problem once, I tried installing Binutils 2.16, but
still the same error was  coming , while configuring 2.16. ?

How do we correct the problem with the linker ?


A candle loses nothing if it is used to light another one!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]