bug-binutils
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug gold/10400] Gold produces incorrect debug and unwind info when inco


From: cvs-commit at gcc dot gnu dot org
Subject: [Bug gold/10400] Gold produces incorrect debug and unwind info when incompatible COMDAT sections are present
Date: 17 Jul 2009 01:07:46 -0000

------- Additional Comments From cvs-commit at gcc dot gnu dot org  2009-07-17 
01:07 -------
Subject: Bug 10400

CVSROOT:        /cvs/src
Module name:    src
Changes by:     address@hidden  2009-07-17 01:07:34

Modified files:
        gold           : ChangeLog layout.cc layout.h object.cc object.h 
                         plugin.cc 

Log message:
        PR 10400
        * layout.h: #include <map>.
        (class Kept_section): Change from struct to class.  Add accessors
        and setters.  Add section size to Comdat_group mapping.  Change
        Comdat_group to std::map.  Add is_comdat_ field.  Add
        linkonce_size field in union.
        (class Layout): Update declaration of find_or_add_kept_section.
        Don't declare find_kept_object.
        * layout.cc (Layout::find_or_add_kept_section): Remove candidate
        parameter.  Add object, shndx, is_comdat, and is_group_name
        parameters.  Change all callers.  Adjust for new Kept_section.
        (Layout::find_kept_object): Remove.
        * object.cc (Sized_relobj::include_section_group): Update use of
        Kept_section.  Rename secnum to shndx.  Only record
        Kept_comdat_section if sections are the same size.
        (Sized_relobj::include_linkonce_section): Update use of
        Kept_section.  Only record Kept_comdat_section if sections are the
        same size.  Set size of linkonce section.
        (Sized_relobj::map_to_kept_section): Update call to
        get_kept_comdat_section.
        * object.h (class Sized_relobj): Rename fields in
        Kept_comdat_section to drop trailing underscores; change object
        field to Relobj*.  Change Kept_comdat_section_table to store
        struct rather than pointer.
        (Sized_relobj::set_kept_comdat_section): Remove kept parameter.
        Add kept_object and kept_shndx parameters.  Change all callers.
        (Sized_relobj::get_kept_comdat_section): Change return type to
        bool.  Add kept_object and kept_shndx parameters.  Change all
        callers.
        * plugin.cc (Pluginobj::include_comdat_group): Update call to
        Layout::find_or_add_kept_section.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gold/ChangeLog.diff?cvsroot=src&r1=1.257&r2=1.258
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gold/layout.cc.diff?cvsroot=src&r1=1.131&r2=1.132
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gold/layout.h.diff?cvsroot=src&r1=1.67&r2=1.68
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gold/object.cc.diff?cvsroot=src&r1=1.95&r2=1.96
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gold/object.h.diff?cvsroot=src&r1=1.75&r2=1.76
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gold/plugin.cc.diff?cvsroot=src&r1=1.15&r2=1.16



-- 


http://sourceware.org/bugzilla/show_bug.cgi?id=10400

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]