[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug binutils/12844] New: TARGET is undefined in bucomm.c

From: hazelnusse at gmail dot com
Subject: [Bug binutils/12844] New: TARGET is undefined in bucomm.c
Date: Sun, 5 Jun 2011 09:07:03 +0000


           Summary: TARGET is undefined in bucomm.c
           Product: binutils
           Version: 2.21
            Status: NEW
          Severity: normal
          Priority: P2
         Component: binutils
        AssignedTo: address@hidden
        ReportedBy: address@hidden

I'm running Kubuntu 11.04 on x86_64 and have downloaded binutils-2.21 and after
untaring I run:
mkdir build
cd build

and I get this error:

gcc -DHAVE_CONFIG_H -I. -I../../binutils  -I. -I../../binutils -I../bfd
-I../../binutils/../bfd -I../../binutils/../include
-Dbin_dummy_emulation=bin_vanilla_emulation  -W -Wall -Wstrict-prototypes
-Wmissing-prototypes -Wshadow -Werror -g -O2 -MT bucomm.o -MD -MP -MF
.deps/bucomm.Tpo -c -o bucomm.o ../../binutils/bucomm.c
../../binutils/bucomm.c: In function ‘set_default_bfd_target’:
../../binutils/bucomm.c:160:24: error: ‘TARGET’ undeclared (first use in this
../../binutils/bucomm.c:160:24: note: each undeclared identifier is reported
only once for each function it appears in
make[4]: *** [bucomm.o] Error 1

The same thing happens in the daily snapshot of binutils.  I have not found
this error anywhere via Google, and the source simply says:

/* The macro TARGET is defined by Makefile.  */
  const char *target = TARGET;

Obviously, TARGET is not getting defined, but I don't know why.  I have tried
setting the --target configure option (--target=arm-eabi, in my particular
case), but this does not fix it.

It would be great to know what I'm doing wrong or if this is a bug.

Configure bugmail: http://sourceware.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]