[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: question on gnu ld on mac

From: Tristan Gingold
Subject: Re: question on gnu ld on mac
Date: Thu, 20 Jun 2013 09:56:33 +0200

On Jun 19, 2013, at 11:31 AM, Merijn van de Klundert <address@hidden> wrote:

> Dear member or developer of binutils,
> I've tried to install gnu ld on my macbook (I need this to compile a certain 
> makefile, which containts options that are not recognized by the linker of 
> snow leopard. This makefile runs smooth on a linux distribution with GNU ld).
> basically, everything in binutils compiles (i.e. configure, make and make 
> install work without error). For example running these in the top directory 
> works and do so as well in for example the gas or gold directory.
> I can run configure and make flawless in the ld directory, however make 
> install gives an error:
> install: ldscripts/*: No such file or directory
> I tried to make a softlink to this directory (which is empty) and it doesn't 
> help. 
> However, in ld/bin is now a file called ld 
> When I try to use this as linker I get the error message:
> /Users/merijnvandeklundert/PhD/Castor/Linker/binutils-2.23.2/ld/bin/ld: 
> unrecognised emulation mode: 
> Supported emulations: 
> So it seemed to have failed still. (also I tried running make all-ld from the 
> top directory, which runs but doesn't seem to create an executable).
> I looked into installing it via macports, but some macports webpage seems to 
> indicate that gnu ld simply won't run on mac: 
> http://trac.macports.org/ticket/24471
> Is this true or am I doing something wrong?

That's correct. GNU ld hasn't been ported to target darwin.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]