[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug binutils/21504] New: objcopy fails --prefix-symbols on armv7

From: cocoarui09 at gmail dot com
Subject: [Bug binutils/21504] New: objcopy fails --prefix-symbols on armv7
Date: Sat, 20 May 2017 11:15:48 +0000


            Bug ID: 21504
           Summary: objcopy fails --prefix-symbols on armv7
           Product: binutils
           Version: 2.28
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: binutils
          Assignee: unassigned at sourceware dot org
          Reporter: cocoarui09 at gmail dot com
  Target Milestone: ---

Hi there,

   I've installed binutils 2.28 via homebrew on Mac os sierra 10.12.4, and
changed gobjdump name to objdump, also the objcopy.

   I've checked the .o file by: `lipo -info hmac_md5.o`,
and it print out: 
`Non-fat file: hmac_md5.o is architecture: armv7`. 
then I tried change symbol prefix name by:
`objcopy --prefix-symbols=hc_ hmac_md5.o`
and it print out:
`gobjcopy: hmac_md5.o: file format error`

and when I typed in console:
`objdump -t hmac_md5.o`
it print out:
`hmac_md5.o:     file format mach-o-arm`

   BTW, I also tried the arm64 hmac_md5.o, it workd well. Please help.

You are receiving this mail because:
You are on the CC list for the bug.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]