[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS For NT V1.10 Permission Denied Upon Check In

From: Trevor Vella
Subject: CVS For NT V1.10 Permission Denied Upon Check In
Date: Fri, 27 Jul 2001 16:24:04 +1000


I am running CVS 1.10 NT server edition.
Whenever I attempt to commit a changed file (text file) into the repository I get the following error:

"cvs [commit aborted]: cannot rename file G:\src\cvsroot\CVSROOT/nae/src/au/com/ot/nae/,NAE.java, to G:\src\cvsroot\CVSROOT/nae/src/au/com/ot/nae/NAE.java,v: Permission denied"

The repostory is accessed through an NT mounted drive, in this case my G drive. I am running the CVS executable locally.

I tried setting the CVSUMASK variable to 000 I this using the following command:
set CVSUMASK=000

I checked the environment variable was correctly set and issued the same commit command, and got the same error.

CVS attempts to create a read-only version of the lock file during the commit process. It doesn't seem to be able to delete it, I think because it is read-only.

Do you know of any work arounds? We are really stuck on this problem.

Trevor Vella

Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

reply via email to

[Prev in Thread] Current Thread [Next in Thread]