[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvs hangs using ssh

From: Dick Balaska
Subject: Re: cvs hangs using ssh
Date: Wed, 03 Jul 2002 22:55:52 -0400

>Lynn Quam wrote on Thu, 9 May 2002 19:03:22 -0700:
>>Derek Robert Price wrote:
>>> So, when this happens, is the CVS executable still running on the server 
>>> or is it some other process?
>>After "cvs update" hung without exiting I ran:
>>On the server:
>>ps -auwx | fgrep quam
>>quam     21304  0.1  0.2 2192 1888 pts/4    S 18:40:37  0:00 -tcsh
>>quam     21374  0.0  0.1 1040  760 pts/4    S 18:51:42  0:00 fgrep quam
>>As you can see, "cvs server" and "tcsh -c cvs server" exited on the
>>server side.  But ssh on the client (local) side is hung.
>Sounds like something that needs to be reported to the ssh people.

[ I'm sorry, i didn't subscribe to this spam laden list. ]

I am setting up a minty fresh Slakware 8.1-rc2 server,
which came with cvs 1.11.2 installed.

I am seeing this same symptom, the "hang after 'cvs co' completes".

In my case though, the 'cvs server' process does not exit.  If i kill
it, the client terminates normally.

With a cygwin client (cvs 1.11), cvs runs fine in ext/ssh or pserver mode.
With a local 1.11 GNU/Linux client both ext and pserver hang.
With a remote 1.11.1p1 GNU/Linux client, ext hangs (no pserver test).

I have a 4 year old cvs server that runs great, so i started swapping
out parts with it.  Replacing openssl and openssh with my old working copies
made no difference.

Building 1.11.2 from the source made no difference.

What worked for me was to build 1.10.4.  That works great.

           `-._        ________-_______        "----
      //_| | \         dik_buckosoft_com          / | |_\\
     (_____|_|__= Guilford CT +1.203.458.0389  =__|_|_____)
     _\_____=___   http://www.buckosoft.com     ___=_____/_
Early Net Poetry:
Wustl, Wustl, ERR RIP MIT BOOT, BIND Wustl

reply via email to

[Prev in Thread] Current Thread [Next in Thread]