[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: More on 1.11.2 corruption problem

From: Mike Quinn
Subject: Re: More on 1.11.2 corruption problem
Date: Thu, 19 Sep 2002 08:06:37 -0700

We get all kinds of error messages -

unrecognized command /x## in <file>

unexpected EOF in diff in <file>

are the two most common - and looking at the text of the files they are 

And 1.11.2 is not just noticing it - we tried 4 different versions of CVS 
back to 1.9.xx and all saw corruption after the fact and not before.

Yes - checking out branches without adding a tag works just fine with  both 
1.11.2 and
the earlier versions of CVS.  After adding the tag all versions are upset...

I ran my own script and checked out 100 different branches and it worked fine 
adding the branch, and breaks big-time afterwards.

I'm getting the perl script and will run it, but I don't expect it to find any 
corruption -

I will also look and see if I can find some inocuous files with corruption for
diffing purposes.
-Mike Quinn

*********** REPLY SEPARATOR  ***********

On 9/19/2002 at 10:51 AM lawrence.jones@eds.com wrote:

>Mike Quinn writes:
>> configuration is a CVS database in an NFS or locally-mounted repository
>(I can
>> reproduce it either way),
>If you've been working with an NFS-mounted repository, it's entirely
>possible that it's already corrupted and 1.11.2 is just noticing it
>where earlier versions didn't.
>> we added a branch tag, and at that point most of our CVS database became
>> (checkouts, updates, diffs all complain about the format of the files).
>It would be helpful to know exactly what error message(s) you get.
>>  Both
>> cvs tag and cvs rtag will reproduce the problem. Nothing special - just
>> cvs tag -b -r <branch> <newbranch>      or the rtag equivalent
>> I've restored our database from a backup, and if I add a tag, I can
>> the problem.  Everything looks fine if you check out the HEAD of the
>tree, but
>> if you try to check out any branch tag, you will get corruption problems.
>Have you tried checking out a branch *without* adding a new tag?  My
>guess is you'll have exactly the same problem.  Donald Sharp posted a
>perl script a while back to check a repository for corruption -- I
>suggest you get it and run it:
>       <http://mail.gnu.org/pipermail/info-cvs/2001-June/015932.html>
>-Larry Jones
>I won't eat any cereal that doesn't turn the milk purple. -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]