[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: New Patches for SCO OpenServer 5.0.X and UnixWare 7.1.X and OpenUNIX

From: Derek Robert Price
Subject: Re: New Patches for SCO OpenServer 5.0.X and UnixWare 7.1.X and OpenUNIX 8.0.0
Date: Fri, 09 May 2003 13:37:38 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02

Boyd Lynn Gerber wrote:

I pulled the stable branch and this is what I get.  Configure thinks that
there is a S_ISSOCK but there is not.  Some where it has to be defined.

gcc -g -O2 -o cvs add.o admin.o annotate.o buffer.o checkin.o checkout.o
classify.o client.o commit.o create_adm.o cvsrc.o diff.o edit.o entries.o
error.o expand_path.o fileattr.o filesubr.o find_names.o hardlink.o hash.o
history.o ignore.o import.o lock.o log.o log-buffer.o login.o logmsg.o
main.o mkmodules.o modules.o myndbm.o no_diff.o parseinfo.o patch.o rcs.o
rcscmds.o recurse.o release.o remove.o repos.o root.o rsh-client.o run.o
scramble.o server.o socket-client.o status.o subr.o tag.o update.o
version.o vers_ts.o watch.o wrapper.o zlib.o ../d iff/libdiff.a
../lib/libcvs.a ../zlib/libz.a -lsocket -lnsl Undefined first referenced
symbol                             in file
S_ISSOCK                            buffer.o
cvs: fatal error: Symbol referencing errors. No output written to cvs
collect2: ld returned 1 exit status
make[2]: *** [cvs] Error 1
make[2]: Leaving directory `/usr/zenez/build/osr5/ccvs/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/zenez/build/osr5/ccvs'
make: *** [all] Error 2

This is the same error I was getting before.  S_ISSOCK is in a few
files and does not have any definition.  That is why I made the
changes to system.h  I found that the change I sent only worked with the
Native compilers.  This change now works with both gcc and cc.

Is it possible that one of the includes is being skipped for some reason on your platform? Or maybe you didn't `make distclean' before updating and rerunning configure? I added a test compile of the following code to the configure script:

#include <sys/stat.h>
int main( int argc, char **argv )
   int a;

I can't imagine that that compiles on your platform unless S_ISSOCK is defined in sys/stat.h. Unless maybe I typo'd the AC_DEFINE_UNQUOTED portion... which I did, but the typo shouldn't have caused the error message you reported.

I just checked in a fix for my typo. Could you `make distclean' your source, pull down the new version, configure it, and test it again. Then please send me your `config.log' if it still isn't working.



Email: derek@ximbiot.com

Get CVS support at <http://ximbiot.com>!
Cynic:  Someone who smells the flowers and looks for the casket

reply via email to

[Prev in Thread] Current Thread [Next in Thread]