[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Wierd test failure on OS X

From: Derek Robert Price
Subject: Wierd test failure on OS X
Date: Sat, 28 Jun 2003 00:28:51 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02

Has anyone seen anything like this? This test just started failing on OS X during nightly testing on the 13th. It passes on all other platforms. I'm thinking I might try backing out each individual change on the 12th and rerunning the suite until it passes, but the behavior is very wierd. I cannot reproduce the bug unless I run the entire test suite. If I run the entire test suite the following test:

         dotest_fail checkout_repository-1 \
"${testcvs} co -d ${CVSROOT_DIRNAME} CVSROOT" \
"${PROG} \[checkout aborted\]: Cannot check out files into the repository itself" \ "${SPROG} \[server aborted\]: absolute pathnames invalid for server (specified \`${CVSROOT_DIRNAME}')"


absolute pathnames invalid for server (specified `/private/tmp/cvs-nightly/cvs-sanity/cvsroot')

The relavant part appears to be the missing "cvs [server aborted]: ". There actually _is_ a place where the second message could be printed but it isn't obvious to me what the cause might be and I haven't been able to use the debugger since, like I said, I cannot reproduce the problem.

Just looking for clues.  Thanks.



Email: derek@ximbiot.com

Get CVS support at <http://ximbiot.com>!
If a nation expects to be ignorant and free in a state of civilization, it
expects what never was and never will be...  if we are to guard against
ignorance and remain free, it is the responsibility of every American to be
                        - Thomas Jefferson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]