[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Urgent !!! Problem in checking out files from CVS repository running on

From: Victor
Subject: Urgent !!! Problem in checking out files from CVS repository running on RedHat Advanced
Date: 6 May 2004 16:36:07 -0700

Dear Sir,

I am working on installing the CVS 1.12.7 (have already tried the
1.11.1p1) on the Linux RedHat Advanced Server 2.1.

Everything setup all right (and I can used intellij to load the source
code into the CVS1.12.7 repository, the real problem is in checking
out the source from the CVS and I get the read lock failure message):
I follow the steps bellow:

To get it simple, I used the root user to set this up:

0. Create a group called "cvs" and a user call "victors" and put the
user "victors" into the "cvs" group.
1. Installed the CVS successfully.
2. Created a new repository root succcessfully: /cvs1.12.7 and changed
the group ownership recursively right under the cvs1.12.7 root
directory to the "cvs" group, and then also right under the /cvs1.12.7
directory, I ran this: chmod ug+rwx . CVSROOT
3. Then I registered the cvspserver as a service, updated the
xinetd.conf accordingly, updated and restared the xinetd successfully.

And finally I can use the nmpa localhost | grep 2401 and I can see the
xinetd is running.

Now I login using my id say "victors" and I am at my home directory,
and I used the following command:

cvs -d :local:/cvs1.12.7 co CVSROOT

However, it shows me the following error:

cvs checkout: Updating CVSROOT
cvs checkout: cannot create read lock in repository
`/cvs1.12.7/CVSROOT': No such file or directory
cvs [checkout aborted]: read lock failed - giving up

Please know that this problem should not be related to the permission
setting because of the following reasons:

1. As you can see from the above there is NO permission error showing
2. I have double checked the permission setting on the directories in
the CVS ropository and they are all right, and I even used the root
user to try and it comes out with the same error message.

I have done a lot of research regarding this problem on the internet
and found no help and all of the similar problems are related to their
incorrect permission setting...But in my case there is no problem with
the permission setting.

I am now wondering whether this is the bug in CVS or there is the bug
on the RedHat Advanced Server 2.1, however I believe this looks more
likely a bug on the CVS rather than on the O/S.

As I need URGENTLY to finish the setup in order to let the development
activities to proceed smoothly, it would be EXTREMELY HIGHLY
appreciated if anyone could provide the help on this regard!!!

Thank you very much in advanced!!!!!!

Best Regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]