[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Urgent !!! Problem in checking out files from CVS repository running

From: Mark D. Baushke
Subject: Re: Urgent !!! Problem in checking out files from CVS repository running on RedHat Advanced
Date: Thu, 06 May 2004 18:49:21 -0700

Hash: SHA1

Victor <md38@hotmail.com> writes:

> Dear Sir,

fyi. This is a mailing list filled with all kinds of people, both male
and female

> I am working on installing the CVS 1.12.7 (have already tried the
> 1.11.1p1) on the Linux RedHat Advanced Server 2.1.

Did the older version of cvs work for you previously?

> Everything setup all right (and I can used intellij to load the source

I have no idea what intellij might be.

> code into the CVS1.12.7 repository, the real problem is in checking
> out the source from the CVS and I get the read lock failure message):
> I follow the steps bellow:
> To get it simple, I used the root user to set this up:
> 0. Create a group called "cvs" and a user call "victors" and put the
> user "victors" into the "cvs" group.


> 1. Installed the CVS successfully.

How do you know you did this?

Did you run the command:

    cvs -d :local:/cvs1.12.7 init

and if so, did it work for you? I not, what happened when you
did something like:

   mkdir /cvs1.12.7
   chgrp cvs /cvs1.12.7
   chmod g+rwxs /cvs1.12.7
   login victor
   cvs -d :local:/cvs1.12.7 init
   cvs -d :local:/cvs1.12.7 checkout CVSROOT

Note: I suggest against having the cvs version number as a part of the
pathname to your cvs root. It will be confusing over time. I would
probably also suggest you not put it on the root filesystem, but on its
own filesystem to also more focused backups to occur.

> 2. Created a new repository root succcessfully: /cvs1.12.7 and changed
> the group ownership recursively right under the cvs1.12.7 root
> directory to the "cvs" group, and then also right under the /cvs1.12.7
> directory, I ran this: chmod ug+rwx . CVSROOT

Note that you probably want rwxs permissions on the CVSROOT/.. directory.

> 3. Then I registered the cvspserver as a service, updated the
> xinetd.conf accordingly, updated and restared the xinetd successfully.

Given this comment, I presume you intend to use :pserver: in the general
case to access this repository...?

> And finally I can use the nmpa localhost | grep 2401 and I can see the
> xinetd is running.
> Now I login using my id say "victors" and I am at my home directory,
> and I used the following command:
> cvs -d :local:/cvs1.12.7 co CVSROOT
> However, it shows me the following error:
> cvs checkout: Updating CVSROOT
> cvs checkout: cannot create read lock in repository
> `/cvs1.12.7/CVSROOT': No such file or directory
> cvs [checkout aborted]: read lock failed - giving up
> Please know that this problem should not be related to the permission
> setting because of the following reasons:
> 1. As you can see from the above there is NO permission error showing
> 2. I have double checked the permission setting on the directories in
> the CVS ropository and they are all right, and I even used the root
> user to try and it comes out with the same error message.

I can see nothing from your message you only summarized your operations,
you didn't actually show us anything.
> I have done a lot of research regarding this problem on the internet
> and found no help and all of the similar problems are related to their
> incorrect permission setting...But in my case there is no problem with
> the permission setting.

How can we know that is true?

> I am now wondering whether this is the bug in CVS or there is the bug
> on the RedHat Advanced Server 2.1, however I believe this looks more
> likely a bug on the CVS rather than on the O/S.

More likely is that this is pilot error.

> As I need URGENTLY to finish the setup in order to let the development
> activities to proceed smoothly, it would be EXTREMELY HIGHLY
> appreciated if anyone could provide the help on this regard!!!

Your urgent requirements are not necessarily our concern.

> Thank you very much in advanced!!!!!!

        Good luck,
        -- Mark
Version: GnuPG v1.2.3 (FreeBSD)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]