[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Urgent !!! Problem in checking out files from CVS repository running

From: Mark D. Baushke
Subject: Re: Urgent !!! Problem in checking out files from CVS repository running on RedHat Advanced
Date: Fri, 07 May 2004 09:38:16 -0700

Hash: SHA1

Victor <md38@hotmail.com> writes:

> Thanks for your message, and please let me further explain what
> happened:'
> > > I am working on installing the CVS 1.12.7 (have already tried the
> > > 1.11.1p1) on the Linux RedHat Advanced Server 2.1.
> > 
> > Did the older version of cvs work for you previously?
> I only tried the CVS version 1.11.1p1 and 1.12.7

Did 1.11.1p1 work for you? If it came from your vendor, it probably has
all of the relevant security patches already available to it.

cvs 1.12.7 is the feature release and is probably still moving fast
enough that the cvsgui.org project that provide wincvs may not have
caught up with all of the interface changes for it as yet.

If you want the most recent stable release, that would be cvs 1.11.15
and it should work fine with wincvs.org, but your mileage may vary.

> > > 1. Installed the CVS successfully.
> > 
> > How do you know you did this?
> Because I can use the wincvs to load source into the CVS repository
> running on RadHat Advanced Server 2.1 but failed in checking them out,
> so to be more accurated, it's partially successful.

Hmmm... how did you 'load source' into the repository? Via a 'cvs add'
and 'cvs commit' set of operations or via a 'cvs import' operation?
(Yes, I am aware that there is some difference in how wincvs works, but
as I don't use windows it has been a long time since I actually played
with wincvs myself and I was curious which functions seem to work and
which do not).

> > Did you run the command:
> > 
> >     cvs -d :local:/cvs1.12.7 init
> > 
> > and if so, did it work for you? I not, what happened when you
> > did something like:
> > 
> >    su
> >    mkdir /cvs1.12.7
> >    chgrp cvs /cvs1.12.7
> >    chmod g+rwxs /cvs1.12.7
> >    exit
> >    login victor
> >    cvs -d :local:/cvs1.12.7 init
> >    cvs -d :local:/cvs1.12.7 checkout CVSROOT
> Yes, I ran the command on the server side: cvs -d /cvs1.12.7 init and
> successfully created the repository. After that, I did the following
> as the root user:
> cd /cvs1.12.7
> chgrp -R cvs .
> chmod ug+rwx . CVSROOT
> chmod g+s . CVSROOT

Okay, that looks reasonable. If you look in /cvs1.12.7, do you see the
stuff that you 'loaded' from the Wincvs side present in the repository?

> > Given this comment, I presume you intend to use :pserver: in the general
> > case to access this repository...?
> Correct.


> > 
> > Your urgent requirements are not necessarily our concern.
> Understood, and thanks for your message anyway. And herewith my
> xinetd.conf file:
> service cvspserver
> {
>    Port = 2401
>    socket_type = stream
>    protocol = tcp
>    wait = no
>    user = root
>    passenv = PATH
>    server = /home/victors/bin/cvs/bin/cvs # temporarily for version
> 1.12.7
>    server_args = --allow-root=/var/cvstest --allow-root=/cvs1.12.7 -f
> pserver

Did you mail user agent wrap the above two lines of is that how it
actually appears in your configuration?

You probably only really need the

  server = /home/victors/bin/cvs/bin/cvs
  server_args = -f --allow-root=/cvs1.12.7

for those two lines.

>    log = /var/log/cvslog
> }

I'll assume you have read the setup instructions on
http://www.cvshome.org/docs/manual/current/cvs_2.html and gone thru the
trouble shooting steps as well right?

Are you able to login as user victor and do

  cvs -d :local:/cvs1.12.7 checkout CVSROOT
  cvs -d :local:/cvs1.12.7 release -d CVSROOT
  cvs -d :pserver:/cvs1.12.7 checkout CVSROOT

with no problems?

        -- Mark
Version: GnuPG v1.2.3 (FreeBSD)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]