[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Shell script failed to read in .cvspass file

From: Sherwin, Ziying (NIH/NLM)
Subject: Shell script failed to read in .cvspass file
Date: Thu, 9 Sep 2004 16:44:47 -0400

We are trying to write a shell script to automatically check for cvs updates
using anonymous login. We are using cvs version 1.11.17. There is no
password set on CVS server for anonymous users. In our script, we set
CVSROOT to use pserver, set CVS_PASSFILE to read a .cvspass file from
previous logins and then use:

    cvs status <filename>

To check for updates.

However, even with the presence of the cvs password file, we are prompted
for password every single time, and, worst of all, the first time entering
correct password always leads to failure of authentication.

We also tried to set CVS_PASSWORD environement variable, which, according to
documentation, will override all previous settings. It does not work either.

Finally, we tried to feed in the password from command line, like:

    echo "password" | cvs status <filename>

It does not make any difference as well.

Does anyone have similar experience? How to solve this problem? Can checking
for CVS update be done automatically on UNIX operating system? Thanks in

reply via email to

[Prev in Thread] Current Thread [Next in Thread]