[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Out of memory error

Subject: Out of memory error
Date: Wed, 14 Sep 2005 11:05:46 -0700

I am having difficulties in migrating my CVS repository to a new server.
The new server is running a newer version of cvs (1.11.16) while the old
repository machine has 1.11.8.

I have numerous modules defined for the repository in the modules file.
These modules encompass in the neighborhood of 2000 separate files.
When I go to check out that module, I am getting the following error:

cvs [checkout aborted]: out of memory; can not allocate 13139854 bytes

This error does not occur when I use version 1.11.8 of cvs, it does with
1.11.16.  Furthermore, if my CVSROOT is set to just using a local file
system the checkout succeeds, this error is only encountered when I am
using Pserver to get to the repository.

Finally, the module that I am encountering the error with has 1920 files
in it.  There is one file that is 32MB in size.  If I eliminate that
large file, or retag to a smaller version, that is 15MB in size, I do
not encounter this error.  I can check out the 32MB file by itself, I
only have the problem when I check it out as part of the module.

I am using IBM hardware with AIX version 5.1.

I have already tried increasing the ulimits for the user id that is used
to process the cvs requests.  I have increased them to unlimited, but
still get the error with the same exact number of bytes that you see

Any help would be appreciated.

Jeff Oransky

Technical Architect
BIS Developer Support Team
Business Integration Services
Office: (925)901-7378
Pager:  (925)340-7665
2600 Camino Ramon, #4E700LL
San Ramon, CA 94583

reply via email to

[Prev in Thread] Current Thread [Next in Thread]