[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #14840] zlib.c implementation in 1.12.12+ still broken

From: Rahul Bhargava
Subject: [bug #14840] zlib.c implementation in 1.12.12+ still broken
Date: Fri, 21 Oct 2005 18:29:46 -0700
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4


                 Summary: zlib.c implementation in 1.12.12+ still broken
                 Project: Concurrent Versions System
            Submitted by: b_rahul
            Submitted on: Fri 10/21/05 at 18:29
                Category: None
                Severity: 3 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
           Fixed Release: None
   Fixed Feature Release: None



The cvs1.12.12+ tree's zlib.c has compatability problems with
several Java based cvs clients - SmartCVS, WANdisco, JetBrains Ideaj etc.
This manifests via cvs commands will hang for some files. See the bundled
test file (add.c from cvs src dir)

We have tested with cvs1.11 tree right upto 1.11.21 and has no problems
interoperating with the cvs server's zlib implementation.

To further confirm the issue we tried with all the zlib levels and the
incompatability remains.

We recompiled with cvs 1.12.12 src with the --with-external-zlib and
dynamically linked the default libz.so on Gentoo and Red Hat Linux distros
(1.1.4) and that works like a charm. While running configure  we noticed :

checking selected ZLIB... external
configure: WARNING: Package ZLIB is more recent than requested external
           (1.2.2 > 1.1.4).  configure with the --without-external-zlib
           option to select the more recent version.
checking that ZLIB library works... yes

Seems like CVS is using 1.2.2, so we downloaded the latest zlib versions
(1.2.3) from  http://www.zlib.net/ and tried it with the cvs 1.12.12 src.
Again no problem, all works like a charm.

This seems to suggest the 1.2.2 version bundled is broken. It may be a good
idea to move to 1.2.3 on the cvs1.12. tree.

Also attached is a testcase tar ball. It includes:
- Ethereal sniff of the client - server traffic when the zlib hang happened
- the src file (add.c) that caused the problem
- The cvs server tmp dir with the partially read (by the cvs pserver process)
add.c file
- The repository RCS file
- An strace capture of the cvs pserver process when it got hung sucking in
the zlib6 compressed add.c file

Hope this provides enough information to debug 1.2.2 zlib, it might be just
simpler to migrate to newer zlib (1.2.3)

Rahul Bhargava


Carbon-Copy List:

CC Address                          | Comment
aahlad@wandisco.com                 | 


File Attachments:

Date: Fri 10/21/05 at 18:29  Name: bug-cvs-zlib.tgz  Size: 24.66KB   By:
testcase file with description in the bug report


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]