[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Réf. : RE: Réf. : RE: CVS 1.12.13 on Win : repository location problem

From: Massimiliano . Maini
Subject: Réf. : RE: Réf. : RE: CVS 1.12.13 on Win : repository location problem
Date: Thu, 10 Nov 2005 15:52:44 +0100

>>>I've just downloaded and compiled CVS 1.12.13 on WinXP, but it has a
>>>strange behavior.
>>>I try to tell him the repositiory is on L: (btw, it is a network drive
>>>managed by NFS Maestro) but it complains :
>>>  >> C:\temp>cvs-new -dL:\ESDEV\REPOSITORY_ES2 co -d. eel
>>>  >> cvs-new [checkout aborted]: Failed to resolve path:
>>>  `L:\ESDEV\REPOSITORY_ES2': No such file or directory
>>>If I put slashes instead of backslashes :
>>>  >> C:\temp>cvs-new -dL:/ESDEV/REPOSITORY_ES2 co -d. eel
>>>  >> cvs-new [checkout aborted]: reading from server: No such file or
>>>  >>
>>>  >> C:\temp>L : hôte inconnu
>>>  >> rsh : impossible d'établir la connexion.
>>>I tried to init a repository on my C: drive and it worked (I also
>>>a few files),
>>>but when I try to access t with cvs -d C:\myrepository it complains in
>>>same way.
>>>What's wrong here ?
>>>NOTE : this was fine with my old cvs.exe (1.11.5), even with the network
>>>The only thing that wasn't working was the checkout/export of modules
>>>defined in my
>>>modules file. (cvs was unable to find the module, but if i do the same
>>>the unix
>>>machine where the repository is, it works without problems). I was
>>>to fix this with the new version ...
>>Perhaps because the CVSROOT directory includes a colon, you must use the
>>:local: prefix so that the software can properly parse the CVSROOT path.
>>Try (using your example):
>>             cvs-new -d:local:L:/ESDEV/REPOSITORY_ES2 co -d. eel
>Doesn't help.
>The strange thing is that if I use the new cvs on an existing local copy
>of my code (checked out with an old cvs.exe from the network repository
>on L:), it works !! An all the Root files in CVs directories ahve the
>same path (L:\ESDEV\REPOSITORY_ES2) ...

I'm using CVS :

- with 1.11.5 (only got the executable) it is unable to "see" the modules
- with 1.12.13 it has problems in finding the repository directory (with
or without :local:)

[If I use CVSNT everything works fine, but it is much slower that 1.11.5]

reply via email to

[Prev in Thread] Current Thread [Next in Thread]