[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problems building feature release on windows

From: Mark D. Baushke
Subject: Re: problems building feature release on windows
Date: Tue, 02 May 2006 11:49:08 -0700

Hash: SHA1

Hi Kelly,

Kelly F. Hickel <kfh@mqsoftware.com> writes:

> Hi,
>             I've been trying for the last day or so to build the feature
> release on windows (so that I can use Rational purify & quantify to look
> at some other issue).  I've had no luck at all.  I've tried 1.12.12,
> 1.12.13 and the tip of the trunk.  I've used VS .Net 2003 and VS .net
> 2005.  I've tried cvsnt.mak and cvsnt.dsp.

I suspect that the current tip-of-trunk CVS sources are not
yet working on Windows. The new OpenPGP signing feature has just been
rolled into the sources and may not yet be shaken down completely.

Personally, I do not have any way to try to do the build myself as I
never use the Windows operating system.

> The .dsp/.dsw files won't load into either version of VS .net that I
> have, it reports that the project files are corrupt.

Very strange. I believe that both 1.12.12 and 1.12.13 were building
without any problems on Windows. Conrad T Pino should be able to tell
you more about the environment he used for building.

        -- Mark

> When I use the .mak files, I can get it to build if I add code for some
> of the wide character stuff (btowc, mbrtowc and wctype) which don't seem
> to be supplied. 

My guess is that your config.h needs to be adjusted. I would have
expected '#undef HAVE_BTOWC' to exist and avoid problems with that. The
current revision of windows-NT/config.h does appear to define
HAVE_MBRTOWC and HAVE_WCTYPE_H, so if your system does not, you may need
to adjust those values.

> When I do that the resulting .exe seems to work but doesn't actually
> do anything with any of the files in the directories of the repo. So,
> if I do a co, I get all the directories and CVS directories, but no
> files.

If you wish to send e-mail with the compilation errors you are getting,
we might be able to fix things.

In the mean time, you should be able to download CVS 1.12.13 in either
source or binary form for Windows and use it without any problems.

> This stuff must build, right? I can download binaries that work fine, so
> someone must have built it......

Indeed. 1.12.12 and 1.12.13 did build, but I do not have details on the
nature of the environment used.

        -- Mark

> -- 
> Kelly F. Hickel
> Senior Software Architect
> MQSoftware, Inc
> 952.345.8677
> kfh@mqsoftware.com
Version: GnuPG v1.4.3 (FreeBSD)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]