[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problems with gserver and 1.12.13

From: Yves Dorfsman
Subject: Re: problems with gserver and 1.12.13
Date: Fri, 19 May 2006 14:04:14 -0600 (MDT)
User-agent: SquirrelMail/1.4.6

> CVS runs fine with pserver, but with gserver, it works once, and then it
> just hangs there:
> cvs -t update
>  -> main loop with CVSROOT=:gserver:cvslab:/cvs/root99/playground
>  -> Connecting to cvslab(999.99.999.99):2401
> The same machine running cvs 1.11 runs fine.
> If I leave the machine alone for say a day, then I am able to make one
> connection again (a co or an update), but then the subsequent ones just
> hang.
> I had originally compiled using Kerberos 1.4.3, then thought the problem
> was
> with kerberos, so recompiled with KB 1.3.6, but get the exact same
> problem.
> As I am writting this, I just had an idea:
> If I do a kdestroy, than a kinit, than I am able to do another
> transaction,
> but then get into the same problem again..... I'm running on Solaris 9,
> and
> the MIT kerberos.
> Has anybody else run into this ?
> Any idea ?

I have grabbed the HEAD from the cvs repository on Savanah, compiled etc..
So first, sure enough the pam problem I was complaining about a week or
so ago is gone (thanks).

Now, the problem is that I cannot get gserver running, regardless of what
I've tried (different versions of kerberos, recompile without pam, etc..).

Has anybody tried to run the latest 1.12 with gserver ?
Problems ?
Did you have to change the kerberos configuration, or parameters when
running CVS ?

I am using these options for the configure:
./configure --enable-pam --with-gssapi=/usr/local/krb --prefix=/usr/local/cvs

The error I am now getting is:
cvs update: GSSAPI authentication failed: No credentials were supplied, or
the credentials were unavailable or inaccessible
cvs [update aborted]: GSSAPI authentication failed: mech_dh: No secret key

kinit, cvs 1.11 with gserver etc.. work fine on this box.

Yves Dorfsman                                             yves@zioup.com

reply via email to

[Prev in Thread] Current Thread [Next in Thread]