[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Return status bug?

From: Mark D. Baushke
Subject: Re: Return status bug?
Date: Mon, 28 May 2007 22:07:34 -0700

Hash: SHA1

David Whitney <dwhitney67@yahoo.com> writes:

> When I run a command similar to "cvs co dirA", the return status is 0.
> When I run a command similar to "cvs co dirA dirB", the return status
> is 1. Even though the command appeared to have succeeded (no error
> messages were printed) and all of the files were retrieved from the
> repository (on a remote server), the return status implies that an
> error occurred. This contradicts what is stated in the CVS
> documentation.
> On my system I am running CVS 1.11.22, and on the remote CVS server
> version 1.11.2 is running.
> I am using the tcsh shell, and I have the following environment
> variables set up:
> CVSROOT=myUserId@cvsserver:/cvs_repository
> CVSREAD=readOnly
> CVS_RSH=ssh
> I am verifying the returned status with the following command:
> $ echo $?
> Can someone verify if what I am experiencing is indeed a bug, and if
> so, when will it be corrected.

The oldest machine I have setup has a client/server of cvs 1.11.18 and
does not exhibit your problem. I don't still have the ancient cvs 1.11.2
release on any machine to test it. I urge you to upgrade to cvs 1.11.22
on the server and see if that helps fix your problem.

        -- Mark

Version: GnuPG v1.4.6 (FreeBSD)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]