[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Curious problem with cvs and bind-mounted dirs

From: aGeorgo
Subject: Re: Curious problem with cvs and bind-mounted dirs
Date: Sat, 1 Dec 2007 01:36:30 +0100

>I've found a curious problem with cvs and directories bind-mounted. If
>one tries to perform any kind of cvs operation inside that dir, cvs
>fails with an error like "cannot get working directory: No such file
>or directory".

>The problem is pretty easy to be reproduced, at least in my setup
>here, based on CVS 1.12.13:

>Any suggestions on how to make it possible to run cvs from inside a
>bind-mounted dir? Can anyone confirm this?

I have the same problem on my machine. I discovered it after I tried CVS in
chroot with bind mounted directories. The problem seems to be in two places.
The configure script does not allow the use of getcwd from libc. It fails
and the fallback getcwd routine which is bundled with CVS is used. This
routine is probably an ancient implementation which cannot handle bind
mounts, so it fails. I tried to force the usage of libc getcwd and after
this change is CVS functional also under bind mount.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]