[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

"received broken pipe signal" when trying to checkout from local reposit

From: Cooper Clauson
Subject: "received broken pipe signal" when trying to checkout from local repository from cron
Date: Thu, 9 Feb 2012 14:37:06 -0800

I *believe* this is a bug--when I try to checkout files from a local repository 
as a cron job, it issues the following output:
cvs checkout: Updating ARCADE
cvs checkout: Updating ARCADE/.settings
cvs checkout: Updating ARCADE/com
cvs checkout: Updating ARCADE/com/site
cvs checkout: Updating ARCADE/com/site/arcade
cvs checkout: Updating ARCADE/com/site/arcade/DAC2005
cvs checkout: Updating ARCADE/com/site/arcade/arana
cvs [checkout aborted]: received broken pipe signal
cvs [checkout aborted]: write error

I'm currently using version 1.12.13, however I had the same issue with 1.11.22 
which prompted me to update to this version, to no avail.  I'm on Red Hat 
Enterprise Linux Client release 5 (Tikanga).

The command I run is:
/usr/local/bin/cvs -d /opt/site.dev checkout -DNOW ARCADE 2> 
The same issue occurs, however, when using "export" instead of "checkout"

An interesting feature of this is that it works if I run the command normally, 
but it fails if run as a cron job.

As workarounds, I've tried having cron launch a new bash process to run the 
command, or run it under a different user, but in neither case did this work.

In my application, this might be a showstopper, since I'd like to be able to 
automate tasks with the source code on the server (like builds, documentation 
generation, and unit testing) as cron jobs, but if I can't export the source 
from the repository, I don't see how this is possible (if anyone has any ideas, 
though, I'm open).  As it is, this might prompt a switch to SVN.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]