[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "received broken pipe signal" when trying to checkout from local

From: Larry Jones
Subject: Re: "received broken pipe signal" when trying to checkout from local
Date: Fri, 10 Feb 2012 16:56:20 -0500

Cooper Clauson writes:
> I *believe* this is a bug--when I try to checkout files from a local 
> repository as a cron job, it issues the following output:
> cvs checkout: Updating ARCADE
> cvs checkout: Updating ARCADE/.settings
> cvs checkout: Updating ARCADE/com
> cvs checkout: Updating ARCADE/com/site
> cvs checkout: Updating ARCADE/com/site/arcade
> cvs checkout: Updating ARCADE/com/site/arcade/DAC2005
> cvs checkout: Updating ARCADE/com/site/arcade/arana
> cvs [checkout aborted]: received broken pipe signal
> cvs [checkout aborted]: write error
> I'm currently using version 1.12.13, however I had the same issue with 
> 1.11.22 which prompted me to update to this version, to no avail.  I'm on Red 
> Hat Enterprise Linux Client release 5 (Tikanga).
> The command I run is:
> /usr/local/bin/cvs -d /opt/site.dev checkout -DNOW ARCADE 2> 
> /home/me/errlog1.log

Since you're using a local repository, CVS is not using any pipes
internally, so the "broken pipe" error must be coming from some external
source.  Is you repository perhaps NFS mounted?  Have you tried
redirecting stdout as well as stderr?
Larry Jones

At times like these, all Mom can think of is how long she was in
labor with me. -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]