[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Possible chgrp bug

From: David Smith-BEng
Subject: Possible chgrp bug
Date: Tue, 11 Sep 2001 12:13:31 +0100

I'm emailing to report a possible bug in chgrp.  I am not a linux expert by
any means, so it is possible that I have misunderstood or misused the
utility, in which case, apologies in advance.

FYI I am using RedHat 7.1 (Kernel 2.4).  The man page reports the version of
fileutils to be 4.0.36.

As "root" I was in a users directory (user "mark") and performed a
        chown -R mark *
which worked as expected.  I then did a
        chgrp -R mark *
but an "ls -la" showed that the group hadn't changed for hidden . files.
The owner HAD taken effect on the hidden . files.

I believe this to be a bug.  The following I am not sure whether it is a bug
or my own stupid mis-use:

I then tried doing
        chgrp -R mark .*
to change the . files.  I realised quite quickly that this was taking longer
than I expected and CTRL-C'ed it.  I found that this command had moved into
the parent (..) directory and was starting to change the group of all files
in all other users home directory.  Luckily I stopped it before it had
processed more than a few directories.  I am not sure if this is expected
behaviour or another bug.

Many thanks,

--Dave Smith


David Smith | Broadcast Systems Engineer

> mailto:address@hidden

This e-mail, and any attachment, is confidential. If you have received
it in error, please delete it from your system, do not use or disclose
the information in any way, and notify me immediately. The contents of
this message may contain personal views which are not the views of the
BBC, unless specifically stated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]