[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug in "more"

From: Bob Proulx
Subject: Re: Bug in "more"
Date: Sun, 23 Sep 2001 18:44:32 -0600

> I found a bug in "more" on RedHat 7.1.  I don't know if the version
> of "more" there is from GNU, since it has no version flag.

Specifically because it has no version flag, I suspect not.  On
systems that use rpm (redhat package manager0 you can use it to
'q'uery what package that 'f'ile is in.  On a RH6.2 system it says

  rpm -qf /bin/more

Which means I can use the knowledge that it is in util-linux to get
'q'uery rpm for 'i'nformation about it.

  rpm -qi util-linux

Which basically just identifies it as being a miscellaneous collection
of stuff.  But it does give you a place to report bugs back to
redhat.  Hope that helps.  If you are curious what other commands are
bundled in that package you can query rpm to 'l'ist them out.

  rpm -ql util-linux

>     setenv MORE "-cs"
> then when I run "more" I get the message
>     Z27) more x
>     more: unknown option "-m"
>     usage: more [-dflpcsu] [+linenum | +/pattern] name1 name2 ...
> Note that the "-m" flag was never specified.

I tried that and it worked fine for me.  You might have an alias for
more which is adding the -m.  Try checking your aliases.

  alias more


P.S. Note that instead of 'more' most people use the more modern
'less' which is a complete rewrite of more but with many new features.
At one time I had heard a rumor that POSIX was going to standardize
this command and call it 'most'.  But sensibilities must have

reply via email to

[Prev in Thread] Current Thread [Next in Thread]