[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: I am not sure whether it is a bug or...

From: Bob Proulx
Subject: Re: I am not sure whether it is a bug or...
Date: Tue, 26 Feb 2002 09:21:01 -0700

> There was a hacker attacked my Linux box and put some files on my machine
> with user number and group number cannot be seen by a common user utility
> such as "userconf."

I am not familiar with any "userconf" program.  If it is important to
the issue at hand then you will need to educate me and provide more
information.  I have never heard of it.

> I tried to remove the file as root, but cannot do that.  Then I
> tried to "chown root [filename]" It also not allow me to do it. I am
> not sure whether it is a bug of chown or I missed something. If this
> is not the right forum to report this. It would be greatly
> appreciated if you can suggest a right forum to find answers for
> this type of questions. Thanks.

If you suspect that it is a bug in the utilities then this is a good
forum.  But if you want to generation discussion on how things work
then I suggest one of the news groups such as comp.unix.misc or
possibly you should read the faqs in news.answers.  Also check out the
utils specific faq here:


If you cannot remove the file as root or change the ownership of the
file as root then something sounds corrupted within your filesystem.
The chown program is small enough that I don't think there are any
hidden bugs there and so I really doubt it is a program bug.  But it
might be something else.  You would need to provide more information
before we would know.

For are more complete bug report please generate a small case where
this behavior you are seeing is illustrated.  Send to the list the
details of the operating system you are using and the --version output
of the programs you are using.  Something like the following.

  uid=0(root) gid=0(root)
  ls -ld ./filename
  -rw-rw-r--    1 bob      bob             0 Feb 26 09:15 ./filename
  chown root:root ./filename
  ls -ld ./filename
  -rw-rw-r--    1 root     root            0 Feb 26 09:15 ./filename
  chown --version
  chown (fileutils) 4.1
  uname -a
  HP-UX strife B.10.20 A 9000/785 unknown

And then please use a subject that somehow relates to the particular
problem you are reporting.  It is very hard to sort through a mailbox
where every subject is 'bug' or 'help'.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]