[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Fileutils on

From: Philip Flip Kromer
Subject: Fileutils on
Date: Wed, 01 May 2002 00:59:27 -0500
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9) Gecko/20020311


I recently built fileutils on an rs6000-ibm-aix machine, and had a weird problem:

I did
  ./configure --prefix=$HOME/pub
everything made OK, the executables were born, happy happy. Then, when I ran gmake check (or any susequent make command), gmake returned the following error in the lib/ directory:
  .deps/__fpending.Po:1: *** multiple target patterns.  Stop.
and in the src/ directory,
  .deps/chgrp.Po:1: *** multiple target patterns.  Stop.

The files all looked pretty much the same; here is __fpending.Po
__fpending.o : \
__fpending.c ../config.h __fpending.h /usr/include/stdio.h /usr/include/standards.h /usr/include/va_list.h /usr/include/sys/types.h /usr/include/sys/inttypes.h /usr/include/sys/m_types.h /usr/include/sys/vm_types.h /usr/include/sys/limits.h /usr/include/float.h __fpending.c :
../config.h :
__fpending.h :
/usr/include/stdio.h :
/usr/include/standards.h :
/usr/include/va_list.h :
/usr/include/sys/types.h :
/usr/include/sys/inttypes.h :
/usr/include/sys/m_types.h :
/usr/include/sys/vm_types.h :
/usr/include/sys/limits.h :
/usr/include/float.h :

I think the problem is the first line,
   "__fpending.o: \^J __fpending.c [...] __fpending.c :"
The two colons are making make sad. Should there be a newline in there somewhere? Perhaps after the first fpending.c?

I fixed the error by chopping out all references to $(DEPDIR)/anything.Po:

In lib/Makefile, I changed (circa line 214 for me) the line
  DEP_FILES = $(DEPDIR)/__fpending.Po $(DEPDIR)/addext$U.Po \
    $(DEPDIR)/alloca.Po $(DEPDIR)/argmatch$U.Po $(DEPDIR)/atexit.Po \
         ... many more lines
    $(DEPDIR)/xstrtoumax$U.Po $(DEPDIR)/yesno$U.Po
to simply read
and removed all the lines (starting circa line 574) that read
  include $(DEPDIR)/__fpending.Po
  include $(DEPDIR)/addext$U.Po
  include $(DEPDIR)/alloca.Po
         ... many more lines
  include $(DEPDIR)/xstrtoumax$U.Po
  include $(DEPDIR)/yesno$U.Po

and similarly changed src/Makefile.

I know this is crude butchery, but it Worked For Me. Any idea why this happened? Where are the .deps/*.Po files generated? Anyone else have problems on AIX? I got my junk working, but I'd be glad to look for a fix and submit a patch if y'all can suggest things to try.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]