[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug with move

From: Manjusha
Subject: Bug with move
Date: Fri, 3 May 2002 16:40:02 +0530

I am using the Red Hat Linux release 7.1 (Seawolf), Kernel 2.4.2-2smp on a 2-processor i586.
I tried to move a file called "appendtape.sh" owned by root to another file "appendtape.sh.tmp" when I logged in as myself ( not root ). I also belong to backup group ( as shown by the permissions below ). This file "appendtape.sh" is placed in my home directory.
Following is the file and the related permissions.
-rw-r--r--    1 root     backup       2231 Apr 30 23:49 appendtape.sh
Following is the command
$mv appendtape.sh appendtape.sh.tmp
This operation should have failed since no one other than the owner ( in this case root ) should be permitted to move this file. However, this command was successful. We feel that this should not have happened and hence, it is a bug.
We tried the same experiment on SVR4 and Unixware Operating Systems where it failed.
Please let us know if this report is correct and how this needs to be fixed. We would be interested in knowing the fix.
Please acknowledge this mail.
Thanks and Regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]