[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Autoconf, config.in and configure in fileutils 4.1

From: Jim Meyering
Subject: Re: Autoconf, config.in and configure in fileutils 4.1
Date: Sat, 07 Sep 2002 08:29:45 +0200
User-agent: Gnus/5.090008 (Oort Gnus v0.08) Emacs/21.3.50 (i686-pc-linux-gnu)

address@hidden (Bob Proulx) wrote:

> f l <address@hidden> [2002-09-06 19:35:03 -0400]:
>> I modified the source (just a path) of fileutils 4.1 and now
>> I want to compile.
>> So I execute:
>> aclocal -I m4
>> autoconf
>> autoheader
>> automake -a -c
>> And when I want to execute ./configure I got this output:
>> $ ./configure
>> ./configure: line 10: syntax error near unexpected token `;'
>> ./configure: line 10: `' ECHO_T=' ' ;;'
>> I'm using automake 1.6.2 and autoconf 2.53
> A lot of work just to rebuild the existing package.  And you will need
> particular versions of the auto* tools in order to rebuild.  They must
> match what is expected in the *.am files and the configure.ac file.  I
> expect you don't have the right versions.  I am sure Jim will jump in
> with the correct versions needed.  Fortunately for what you want you
> don't need to rebuild the Makefiles or the configure script.

Thanks for replying, Bob.

I suggest that you use the latest test release of the
new coreutils package.  It includes numerous fixes that
have been made since fileutils-4.1.


If you find it necessary to rerun tools like autoconf/automake,
then read the README in that package:

  WARNING:  If you modify files like configure.in, m4/*.m4, aclocal.m4,
  or any Makefile.am, then don't be surprised if what gets regenerated no
  longer works.  To make things work, you'll have to be using appropriate
  versions of automake and autoconf.  As for what versions are `appropriate',
  use the versions of

    * autoconf specified via AC_PREREQ in m4/jm-macros.m4
    * automake specified via AM_INIT_AUTOMAKE in configure.ac

  Usually it's fine to use versions that are newer than those specified.

But note that automake-1.6.2 is *not* newer than 1.6b.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]