[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with cp (copy)

From: David T-G
Subject: Re: Problem with cp (copy)
Date: Tue, 21 Jan 2003 22:56:46 -0500
User-agent: Mutt/1.4i

Phillip --

I've taken the liberty of bouncing your message to the mailing list.
Don't just send to me; I hardly know anything :-)

...and then Mr. Phillip Kimble said...
% David,
% Thanks for the rapid reply & assistance. Here are the results;

Happy to help!

% BTW: I do dislike Windows & Outlook, but everything is setup for my wife
% since I am gone much of the time.Format (MM.DD.YY for sanity sake,
% otherwise, no problem).

Good enough.

%   ls -1 /home/ftp/tmp/2002/01.01.01/* | wc -l 5935
%   ls -1 /home/ftp/tmp/2002/01.02.01/* | wc -l 2919
%   ls -1 /home/ftp/tmp/2002/01.03.01/* | wc -l 4219
%   ls -1 /home/ftp/tmp/2002/01.04.01/* | wc -l 2710
%   ls -1 /home/ftp/tmp/2002/01.05.01/* | wc -l 3632
% As I stated earlier, everything works fine until I reach 05.*.01, Also,

Interesting.  Certainly not what I expected.

% something else I tried & it worked, I can do the following;
% Cp -fa /home/ftp/tmp/2001/07.*.01/ /home/tmp/whatever/ -> Copies
% directories & files


% Change to the directory of /home/tmp/whatever/
% Cp -fa ./07.*.01/* . Copies all files into parent directory.

OK.  And do either of these work for 05?

% This really has me going now. Not sure what the deal is. Also, There are
% two different file systems as well. 
% /home/ftp/tmp resides on /dev/hda3
% /home/tmp/ resides on /dev/ida/c0d0p5
% I really don't see how any of this has something in common. Cp works

Same here.

% fine across file boundaries, the files are not uncommonly large, it can
% copy directories&files, but not files with directories above 04 ???

I don't think it's "above 04"; I think there's something peculiar about
the directory(ies) that have the problem.

I just saw this recently but don't remember the specifics: when you get
"argument list too long" it's actually a shell problem and not a problem
with cp (or any other program).  Perhaps someone else on the list can
chime in.

% Seems abit odd to me, and probably that has never been encountered
% before, I tend to be an odd ball in all environments as well as Linux!

*grin*  Well, hang in there...  There has to be an answer :-)  My
inclination would be to either get access to your system to poke around
or replicate the setup here, since as a sysadmin I can often have a feel
for what may be wrong but as a programmer or coreutils maintainer I'm
hopeless :-)  Others, however, are much more skilled in the latter arena.


David T-G                      * There is too much animal courage in 
(play) address@hidden * society and not sufficient moral courage.
(work) address@hidden  -- Mary Baker Eddy, "Science and Health"
http://justpickone.org/davidtg/      Shpx gur Pbzzhavpngvbaf Qrprapl Npg!

Attachment: pgpl1pWuCFhNv.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]