[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Problem with cp (copy)

From: Mr. Phillip Kimble
Subject: RE: Problem with cp (copy)
Date: Tue, 21 Jan 2003 21:26:19 -0600


Thanks for the rapid reply & assistance. Here are the results;

BTW: I do dislike Windows & Outlook, but everything is setup for my wife
since I am gone much of the time.Format (MM.DD.YY for sanity sake,
otherwise, no problem).

  ls -1 /home/ftp/tmp/2002/01.01.01/* | wc -l 5935
  ls -1 /home/ftp/tmp/2002/01.02.01/* | wc -l 2919
  ls -1 /home/ftp/tmp/2002/01.03.01/* | wc -l 4219
  ls -1 /home/ftp/tmp/2002/01.04.01/* | wc -l 2710
  ls -1 /home/ftp/tmp/2002/01.05.01/* | wc -l 3632

As I stated earlier, everything works fine until I reach 05.*.01, Also,
something else I tried & it worked, I can do the following;

Cp -fa /home/ftp/tmp/2001/07.*.01/ /home/tmp/whatever/ -> Copies
directories & files

Change to the directory of /home/tmp/whatever/
Cp -fa ./07.*.01/* . Copies all files into parent directory.

This really has me going now. Not sure what the deal is. Also, There are
two different file systems as well. 
/home/ftp/tmp resides on /dev/hda3
/home/tmp/ resides on /dev/ida/c0d0p5

I really don't see how any of this has something in common. Cp works
fine across file boundaries, the files are not uncommonly large, it can
copy directories&files, but not files with directories above 04 ???
Seems abit odd to me, and probably that has never been encountered
before, I tend to be an odd ball in all environments as well as Linux!

Phillip --

...and then Mr. Phillip Kimble said...
% Greetings,


% I recently stumbled across a strange problem using cp which I do not %
understand. Here is the scenario; ... % Cp -far
/home/ftp/tmp/2001/01.*.01/* /home/user/admin/tmp/ % 
% All worked well for 01, 02, 03, 04, (Jan, Feb, Mar, & Apr). Once I %
entered 05.*.01, I received the error, "Argument list is too long".

What do you get when you run

  ls -1 /home/ftp/tmp/2002/01.01.01/* | wc -l
  ls -1 /home/ftp/tmp/2002/01.02.01/* | wc -l
  ls -1 /home/ftp/tmp/2002/01.03.01/* | wc -l
  ls -1 /home/ftp/tmp/2002/01.04.01/* | wc -l
  ls -1 /home/ftp/tmp/2002/01.05.01/* | wc -l

at your shell prompt?  I suspect that there are lots of files in .05 but
not so many files in .01 - .04 dirs.


David T-G                      * There is too much animal courage in 
(play) address@hidden * society and not sufficient moral
(work) address@hidden  -- Mary Baker Eddy, "Science and
http://justpickone.org/davidtg/      Shpx gur Pbzzhavpngvbaf Qrprapl

reply via email to

[Prev in Thread] Current Thread [Next in Thread]