[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Memory consumption with cp -l

From: Ole Tange
Subject: Re: Memory consumption with cp -l
Date: Tue, 11 Mar 2003 10:15:33 +0100 (CET)

On Mon, 10 Mar 2003, Ole Tange wrote:

> You can reproduce the error by doing the following:
> wget http://home.tange.dk/~tange/cp-bug/test-set.tgz
> tar xfz test-set.tgz
> cp-4.1 -Rl test-set t2     # Memusage: 18 MB for cp-4.1
> cp-4.5.9 -Rl test-set t3   # Memusage: 5.9 MB for cp-4.5.9

The story is getting weirder by the minute: I happended to discover, that
cpio has a --link option. It seems it does the same as -l. To see if it
had the same problem I ran:

  find test-set -print0 | cpio -p -0 --link t3 -d

This takes up less that 2 MB RAM continously. Just like 'cp -Rl' it fails
if you try to link across devices. I have yet to see a situation where the
find/cpio does not do the same as cp-Rl. If there is no such situation
then maybe cp-Rl should be implemented using the same techniques as
find/cpio? At least find/cpio solved my issue (and I thereby just freed
298 MB RAM *happy*happy*).

If some genie offered you three wishes, would not your first one be,
"Tell me, please, what is it that I want the most!"
  -- Marvin Minsky in

reply via email to

[Prev in Thread] Current Thread [Next in Thread]