[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lindowsOS but can't install software

From: Bob Proulx
Subject: Re: lindowsOS but can't install software
Date: Sat, 24 Apr 2004 13:07:18 -0600
User-agent: Mutt/1.3.28i

Hello Becky

I am one of the users on the address@hidden mailing list and I
am responding to a message you posted there.

Becky Chandler wrote:
> The following message is what I sent to customer care but no answer
> receviced yet as to the bug problem on my system.

Since your vendor is Lindows/Linspire your best source of information
about your particular system will be with them.  However I will try to
explain what is happening.  Hopefully that will help.  But please keep
in mind this is off topic for this mailing list and other members
won't be interested in the discussion since it does not really have
anything to do with fileutils.

> Keep in mind I am getting updates coming in but I can't install
> anything at all because of the following bug message that keeping
> coming up.

Here is the important part of the error message:

> > Package dependency errors
> > Reading Package Lists....
> > Building Dependency Tree....
> > You might want to run 'apt-get-f install' to correct these:
> > Sorry, but the following packages have unmet dependencies:
> > 1breakou2:depends:libc6(>=2.3.1-1)but 2.2.5-6.lindows3
> > is to be installed
> > Depends libpngl2-0 but it is not going to be installed
> > Depends:libsdl-micer1.2(>=1.2.1)but it is not going to be installed
> > Depends:libsdl1.2 debian(>1.2.3)but it is not going to be installed
> > E:Unmet dependents. 
> > Try 'apt-get-f install' with no packages(or specify a solution).

The software installed on your system is installed in small pieces.
Trying to install the entire thing as one piece would be difficult.
So instead it divided up into smaller software packages so that each
may be installed and upgraded individually.  Some packages will
require that other ones be installed first.  Some packages will
require specific versions or later of other packages.

Programs are in packages which depend upon other packages such as
libraries.  Those libraries in turn depend upon other libraries.  This
creates a web of dependencies.  I like to think of it as a tree in the
simple case.  Branches split out and leaves depend upon branches which
depend upon trunks which depend upon the root.

The APT tool (apt-get) manages those dependencies.  When you install a
program apt-get deduces all of the dependencies declared by that
package and by the packages which it needs, the entire branch, and
gathers them all up and then installs them all at one time.  You may
have seen where it downloads all of the pieces and then installs all
of the pieces.  This makes installing software typically very easy.

But if the dependencies in the system gets broken then it takes a
human to correct it.  That is your current problem.  The system has a
conflicting set of dependencies.  It will need help to get out of this
state.  It has been my experience that the only way it could have
gotten into this state is if a human put it into this state.  So I
will go out on a limb and make a guess that someone got it into this
state by installing something incorrectly.

I am guessing that someone tried to install 'lbreakout2' on your
computer.  lbreakout2 is a ball-and-paddle game.  But they did not use
the lindows apt-get software installation and upgrade process to
install it.  Instead they installed it by a manual method and that is
where the breakage on your system occurred.  If you knew exactly what
they did you could undo it and it would fix your system.  I am
guessing that you were not the one who did this or you would have
known.  I am guessing they downloaded a lbreakout2_something.deb file
and used 'dpkg -i lbreakout2_something.deb' as root to install it.
This did not work and they left it broken.  One fix would be to undo
this by running 'dpkg -r lbreakout2' as root.

I think you retyped that in and I think you really meant to type in
'lbreakout2' there.  The critical line from your error output is the

> > 1breakou2:depends:libc6(>=2.3.1-1)but 2.2.5-6.lindows3

The new program needs the C programming language library
(libc6-2.3.1-1) which is not part of lindows.  It can't find it at the
lindows software site.  That is why this is failing.  This particular
lbreakout2 did not come from lindows either and it needs more.

Lindows is based upon and built upon the Debian distribution.  Many of
the programs can be interchanged between them.  But the entire branch
behind it must come with it.  I think someone tried to install a newer
lbreakout2 package from Debian.  But they did not take the
dependencies it required and this is the problem.  I would not
recommend this.  I would recommend that you keep to the packages from
Lindows only since they will have avoid this problem.  Switching
between distributions for package updates is great for the expert who
understands what they are doing.

I don't want to say never mix and match.  But if you start mixing and
matching the system then you need to understand more about how it
works.  The people who build hot-rod cars obviously take parts of many
different cars and put them together and it all works.  Those custom
built cars are wonderful.  But the factory mechanic won't have a clue
as to how it works and won't be able to help you anymore.  So you have
a choice as to whether you want a factory standard car or a custom
hot-rod car.  Neither are terrible but they are very different

> What do I do now. Help asap!!!! Thanks, Becky

I think you can probably fix this by removing lbreakout2 from the
system.  Try removing it using the same method lindows would normally
use to remove software.  Unfortunately I don't know what that is since
I don't use lindows.  If nothing else then become the "superuser" on
your system which is known as the 'root' user and remove it.

  apt-get remove lbreakout2

That is my best guess as to your problem and how to solve it.  I hope
it helps.  But remember, I am not associated with lindows in any way.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]