[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnulib-tool basics

From: Simon Josefsson
Subject: Re: gnulib-tool basics
Date: Mon, 13 Feb 2006 16:45:04 +0100
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/22.0.50 (gnu/linux)

address@hidden (Karl Berry) writes:

> First, regarding gnulib-tool --help.
> --update isn't mentioned under "Operation modes:", although it is one
> of the usages.

I don't know what --update is supposed to do, so I'll leave it to

> I suggest mentioning that --import can also be used for updating,
> something like this (as I understand it from gnulib-tool.texi):
>       --import              import the given modules into the current package;
>                               if no modules are specified, update the
>                               current package.

This seems correct, I added it.

> Second, I tried gnulib-tool --dry-run --update and got this:
>   gnulib-tool: invalid options for 'update' mode
>   Try 'gnulib-tool --help' for more information.
>   If you really want to modify the gnulib configuration of your project,
>   you need to use 'gnulib --import' - at your own risk!
> I don't want to modify the configuration ...

Again, I don't know what --update does... I always use --import.  It
doesn't modify any configuration by default AFAIK.

Does anyone use --update?

> Third, I tried gnulib-tool --dry-run --import and got this output:
>   Module list with included dependencies:
>   File list:
>     lib/dummy.c
>     m4/onceonly_2_57.m4
>   Create directory ./lib
>   Create directory ./m4
>   cp: cannot create regular file `./lib/dummy.c.tmp': No such file or 
> directory
>   gnulib-tool: *** failed
>   gnulib-tool: *** Stop.
> But my configure.ac says:
> gl_EARLY
> gl_SOURCE_BASE(gnulib/lib)
> gl_M4_BASE(gnulib/m4)
> gl_LIB(libgnulib)
> gl_MODULES(getopt)
> gl_INIT
> ... so I would have expected it to know to use gnulib/lib and gnulib/m4,
> not lib/ and /m4.  It's been a while, but my memory is that it did read
> the configure.ac settings last time I tried it.

Yes, someone changed this.  Gnulib-tool now remember those things
internally.  configure.ac will have to include:


and you'll have to invoke gnulib-tool as:

gnulib-tool --import --source-base=gnulib/lib --m4-base=gnulib/m4 
--lib=libgnulib getopt

the next time, this will be remembered, so simply use:

gnulib-tool --import


gnulib-tool --import foo

to add another module.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]