[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: New function: mfile_name_concat.

From: Bruno Haible
Subject: Re: New function: mfile_name_concat.
Date: Thu, 9 Aug 2007 01:07:14 +0200
User-agent: KMail/1.5.4

Jim Meyering wrote:
> I wanted the functionality of file_name_concat, but without
> the exit-on-failure bits.  Here's the result:
>       New function: mfile_name_concat.
>       * lib/filenamecat.c (mfile_name_concat): New function, just like
>       file_name_concat, but return NULL upon failure rather than exiting
>       with a diagnostic.

Now, to keep a consistent (= easy to remember) naming convention, it would be
useful to rename
  file_name_concat -> xfile_name_concat
  mfile_name_concat -> file_name_concat


reply via email to

[Prev in Thread] Current Thread [Next in Thread]