[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: xreadlink: Rewrite as a simple mreadlink wrapper.

From: Bruno Haible
Subject: Re: xreadlink: Rewrite as a simple mreadlink wrapper.
Date: Sun, 26 Aug 2007 16:51:33 +0200
User-agent: KMail/1.5.4

Hi Jim,

> I did most of this weeks ago and just noticed I never checked it in.
> Ok with you, Bruno?

I'll make up my mind on it once you have put an 'mreadlink' module into
gnulib. I don't see such a module in gnulib, nor in coreutils. Remember
that the difference between xreadlink_with_size and xreadlink was that
in one case a (likely good) estimate for the size is already known and in
the other case there is no such estimate.

Also, about the naming convention: In the *printf family of functions,
the prefix 'a' is used to denote a function that allocates memory with malloc:
asprintf vs. sprintf. I would prefer to have a single such convention
in gnulib, not 'a' for some functions and 'm' for others.
And since the 'a' convention comes from glibc, I suggest renaming
'mreadlink_with_size' to 'areadlink_with_size'.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]