bug-gnulib
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lock module improvement


From: Bruno Haible
Subject: Re: Lock module improvement
Date: Sat, 2 Aug 2008 12:15:53 +0200
User-agent: KMail/1.5.4

Yoann Vandoorselaere wrote:
> > Can you propose a reasonable compromise?
> 
> Move the macro code into inline function, use the macro to call the
> appropriate function. The function return the error, the macro abort()
> in case an error is returned. 

OK, sounds acceptable. What naming convention would you propose? We currently
have

     Declaration:         gl_lock_define(extern, name)
     Initializer:         gl_lock_define_initialized(, name)
     Initialization:      gl_lock_init (name);
     Taking the lock:     gl_lock_lock (name);
     Releasing the lock:  gl_lock_unlock (name);
     De-initialization:   gl_lock_destroy (name);

What should be the names of the 4 inline functions?

Bruno





reply via email to

[Prev in Thread] Current Thread [Next in Thread]