bug-gnulib
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH] getdate: rename to get_date


From: Eric Blake
Subject: [PATCH] getdate: rename to get_date
Date: Thu, 30 Sep 2010 09:48:40 -0600

Note: getdate.h is not renamed, to minimize client impact.
Besides, whenever we eventually add getdate-posix, we'll
want to use getdate.m4 and getdate.c for the implementation,
but don't need to worry about getdate.h since getdate() uses
<time.h> for its header.

* modules/getdate: Mark obsolete.  Move old contents...
* modules/get_date: ...to new module name.
* modules/getdate-tests: Move...
* modules/get_date-tests: ...here.
* m4/getdate.m4: Move...
* m4/get_date.m4: ...here, and rename gl_GETDATE to gl_GET_DATE.
* lib/getdate.y: Move...
* lib/get_date.y: ...here.
* tests/test-getdate.c: Move...
* tests/test-get_date.c: ...here.
* doc/posix-functions/getdate.texi (getdate): Update name.
* NEWS: Mention the change.

Signed-off-by: Eric Blake <address@hidden>
---

I went with get_date, and not Bruno's parse-datetime.  Afterall,
parse-duration supplies the parse_duration function, and
get_date supplies the get_date function.

 ChangeLog                                 |   17 +++++++++
 NEWS                                      |    4 ++
 doc/posix-functions/getdate.texi          |    3 +-
 lib/{getdate.y => get_date.y}             |    0
 m4/{getdate.m4 => get_date.m4}            |    4 +-
 modules/get_date                          |   52 +++++++++++++++++++++++++++++
 modules/get_date-tests                    |   14 ++++++++
 modules/getdate                           |   41 ++++-------------------
 modules/getdate-tests                     |   14 --------
 tests/{test-getdate.c => test-get_date.c} |    0
 10 files changed, 98 insertions(+), 51 deletions(-)
 rename lib/{getdate.y => get_date.y} (100%)
 rename m4/{getdate.m4 => get_date.m4} (97%)
 create mode 100644 modules/get_date
 create mode 100644 modules/get_date-tests
 delete mode 100644 modules/getdate-tests
 rename tests/{test-getdate.c => test-get_date.c} (100%)

diff --git a/ChangeLog b/ChangeLog
index 7fdc713..af7ba44 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,20 @@
+2010-09-30  Eric Blake  <address@hidden>
+
+       getdate: rename to get_date
+       Note: getdate.h is not renamed, to minimize client impact.
+       * modules/getdate: Mark obsolete.  Move old contents...
+       * modules/get_date: ...to new module name.
+       * modules/getdate-tests: Move...
+       * modules/get_date-tests: ...here.
+       * m4/getdate.m4: Move...
+       * m4/get_date.m4: ...here, and rename gl_GETDATE to gl_GET_DATE.
+       * lib/getdate.y: Move...
+       * lib/get_date.y: ...here.
+       * tests/test-getdate.c: Move...
+       * tests/test-get_date.c: ...here.
+       * doc/posix-functions/getdate.texi (getdate): Update name.
+       * NEWS: Mention the change.
+
 2010-09-29  Bruno Haible  <address@hidden>

        Separate the module 'waitpid' from the module 'sys_wait'.
diff --git a/NEWS b/NEWS
index 2f03ac1..28ccdcd 100644
--- a/NEWS
+++ b/NEWS
@@ -12,6 +12,10 @@ User visible incompatible changes

 Date        Modules         Changes

+2010-09-30  getdate         This module is deprecated. Please use get_date
+                            for get_date(), or help us write getdate-posix
+                            for getdate().
+
 2010-09-29  sys_wait        This module no longer provides the waitpid()
                             function. If you need this function, you now need
                             to request the 'waitpid' module.
diff --git a/doc/posix-functions/getdate.texi b/doc/posix-functions/getdate.texi
index 6d454a0..156713a 100644
--- a/doc/posix-functions/getdate.texi
+++ b/doc/posix-functions/getdate.texi
@@ -17,5 +17,6 @@ getdate
 MacOS X 10.3, FreeBSD 6.0, NetBSD 3.0, OpenBSD 3.8, Cygwin, mingw, BeOS.
 @end itemize

-Gnulib provides a module @code{getdate} that contains a function 
@code{get_date}
+Gnulib provides a module @code{get_date} that contains a function
address@hidden
 that has similar functionality as the @code{getdate} function.
diff --git a/lib/getdate.y b/lib/get_date.y
similarity index 100%
rename from lib/getdate.y
rename to lib/get_date.y
diff --git a/m4/getdate.m4 b/m4/get_date.m4
similarity index 97%
rename from m4/getdate.m4
rename to m4/get_date.m4
index 5f98229..6cb2e1d 100644
--- a/m4/getdate.m4
+++ b/m4/get_date.m4
@@ -1,4 +1,4 @@
-# getdate.m4 serial 16
+# getdate.m4 serial 17
 dnl Copyright (C) 2002-2006, 2008-2010 Free Software Foundation, Inc.
 dnl This file is free software; the Free Software Foundation
 dnl gives unlimited permission to copy and/or distribute it,
@@ -24,7 +24,7 @@ AC_DEFUN([gl_C_COMPOUND_LITERALS],
   fi
 ])

-AC_DEFUN([gl_GETDATE],
+AC_DEFUN([gl_GET_DATE],
 [
   dnl Prerequisites of lib/getdate.h.
   AC_REQUIRE([AM_STDBOOL_H])
diff --git a/modules/get_date b/modules/get_date
new file mode 100644
index 0000000..fda965f
--- /dev/null
+++ b/modules/get_date
@@ -0,0 +1,52 @@
+Description:
+Convert a date/time string to linear time.
+
+Files:
+doc/getdate.texi
+lib/getdate.h
+lib/get_date.y
+m4/bison.m4
+m4/tm_gmtoff.m4
+m4/get_date.m4
+
+Depends-on:
+c-ctype
+stdbool
+gettime
+intprops
+mktime
+setenv
+unsetenv
+time
+verify
+xalloc
+
+configure.ac:
+gl_GET_DATE
+
+Makefile.am:
+# This rule overrides the Automake generated .y.c rule, to ensure that the
+# get_date.c file gets generated in the source directory, not in the build
+# directory.
+get_date.c: get_date.y
+       $(AM_V_GEN)$(SHELL) $(YLWRAP) $(srcdir)/get_date.y \
+                                     y.tab.c get_date.c \
+                                     y.tab.h getdate.h \
+                                     y.output get_date.output \
+                                     -- $(YACC) $(YFLAGS) $(AM_YFLAGS) && \
+       mv get_date.c get_date.c-t && \
+       mv get_date.c-t $(srcdir)/get_date.c
+lib_SOURCES += get_date.y
+BUILT_SOURCES += get_date.c
+MOSTLYCLEANFILES += get_date.c-t
+MAINTAINERCLEANFILES += get_date.c
+EXTRA_DIST += get_date.c
+
+Include:
+"getdate.h"
+
+License:
+GPL
+
+Maintainer:
+Paul Eggert
diff --git a/modules/get_date-tests b/modules/get_date-tests
new file mode 100644
index 0000000..cb96ff6
--- /dev/null
+++ b/modules/get_date-tests
@@ -0,0 +1,14 @@
+Files:
+tests/test-get_date.c
+tests/macros.h
+
+Depends-on:
+progname
+setenv
+
+configure.ac:
+
+Makefile.am:
+TESTS += test-get_date
+check_PROGRAMS += test-get_date
+test_get_date_LDADD = $(LDADD) @LIBINTL@ $(LIB_CLOCK_GETTIME)
diff --git a/modules/getdate b/modules/getdate
index 2f0fdb2..2f23036 100644
--- a/modules/getdate
+++ b/modules/getdate
@@ -1,49 +1,22 @@
 Description:
 Convert a date/time string to linear time.

+Status:
+obsolete
+
+Notice:
+This module is obsolete. Use the module 'get_date' instead.
+
 Files:
-doc/getdate.texi
-lib/getdate.h
-lib/getdate.y
-m4/bison.m4
-m4/tm_gmtoff.m4
-m4/getdate.m4

 Depends-on:
-c-ctype
-stdbool
-gettime
-intprops
-mktime
-setenv
-unsetenv
-time
-verify
-xalloc
+get_date

 configure.ac:
-gl_GETDATE

 Makefile.am:
-# This rule overrides the Automake generated .y.c rule, to ensure that the
-# getdate.c file gets generated in the source directory, not in the build
-# directory.
-getdate.c: getdate.y
-       $(AM_V_GEN)$(SHELL) $(YLWRAP) $(srcdir)/getdate.y \
-                                     y.tab.c getdate.c \
-                                     y.tab.h getdate.h \
-                                     y.output getdate.output \
-                                     -- $(YACC) $(YFLAGS) $(AM_YFLAGS) && \
-       mv getdate.c getdate.c-t && \
-       mv getdate.c-t $(srcdir)/getdate.c
-lib_SOURCES += getdate.y
-BUILT_SOURCES += getdate.c
-MOSTLYCLEANFILES += getdate.c-t
-MAINTAINERCLEANFILES += getdate.c
-EXTRA_DIST += getdate.c

 Include:
-"getdate.h"

 License:
 GPL
diff --git a/modules/getdate-tests b/modules/getdate-tests
deleted file mode 100644
index ff2945d..0000000
--- a/modules/getdate-tests
+++ /dev/null
@@ -1,14 +0,0 @@
-Files:
-tests/test-getdate.c
-tests/macros.h
-
-Depends-on:
-progname
-setenv
-
-configure.ac:
-
-Makefile.am:
-TESTS += test-getdate
-check_PROGRAMS += test-getdate
-test_getdate_LDADD = $(LDADD) @LIBINTL@ $(LIB_CLOCK_GETTIME)
diff --git a/tests/test-getdate.c b/tests/test-get_date.c
similarity index 100%
rename from tests/test-getdate.c
rename to tests/test-get_date.c
-- 
1.7.2.3




reply via email to

[Prev in Thread] Current Thread [Next in Thread]