[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: mingw and AC_SYS_LARGEFILE

From: Jim Meyering
Subject: Re: mingw and AC_SYS_LARGEFILE
Date: Sun, 15 Apr 2012 19:16:05 +0200

Bruno Haible wrote:
>> the new names, gl_LARGEFILE and USE_64_BIT_OFF_T
>> sound like things that one would use and expect to be set (resp.)
>> even on non-Windows systems.  What do you think about changing
>> the names to make it clear that they are useful only when building
>> on mingw?
> gl_LARGEFILE is the macro for the module 'largefile'. It could also
> be effective on other systems, e.g. Minix, in theory. The name
> 'gl_LARGEFILE' follows the usual naming conventions.

Ok.  This is not a big deal, but so you know why I suggested it: My
thinking was that "gl_LARGEFILE" sounds like a function that would be
generally desirable (like a gnulib-improved version of AC_SYS_LARGEFILE),
whereas in reality it is currently useful only to packages that target

> For USE_64_BIT_OFF_T I agree. I'll use WINDOWS_64_BIT_OFF_T and
> WINDOWS_64_BIT_ST_SIZE instead.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]